Welcome to UK420

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more!

This message will be removed once you have signed in.


Sign in to follow this  
Followers 0
mrevolve

My 1000w DE Adjustawatt ballast just blew up

It's done me well, but of course I don't typically carry a spare. So am only on some smaller CFL bulbs until the local shop opens, argh!

 

Anyone else had this with adjustable? It's around two years. Is that a good age?

 

I've had a magnetic ballast pop but not a digital one. From inspection, some resistors have exploded. However unable to define if they were the fail point or just the result of something else, it's been binned!

 

I might start reviewing other makes. Any tips?

Share this post


Link to post
2 minutes ago, mrevolve said:

It's done me well, but of course I don't typically carry a spare. So am only on some smaller CFL bulbs until the local shop opens, argh!

 

Anyone else had this with adjustable? It's around two years. Is that a good age?

 

I've had a magnetic ballast pop but not a digital one. From inspection, some resistors have exploded. However unable to define if they were the fail point or just the result of something else, it's been binned!

 

I might start reviewing other makes. Any tips?

Id get it out of the bin mate take photos and send them to the manufacturer.And tell them you want a replacement, You should expect more than 2 years out of any type of ballast imho

4 people like this

Share this post


Link to post

My 400w Lumitek digi gave me 6 years before failing, and my 600w Adjustawatt is still going after 5 years, A friend still uses a magnetic ballast he brought more than 15 years ago. As Jimboo said, I'd expect it to last longer. Did it kill the bulb too ? you might be able to get one of those off em too ;)

1 person likes this

Share this post


Link to post
On 22/12/2018 at 6:25 PM, Mugwuffin said:

My 400w Lumitek digi gave me 6 years before failing, and my 600w Adjustawatt is still going after 5 years, A friend still uses a magnetic ballast he brought more than 15 years ago. As Jimboo said, I'd expect it to last longer. Did it kill the bulb too ? you might be able to get one of those off em too ;)

 

Dude it totally killed the bulb as well. I got back from the shop tried to fire it up and it flashed open circuit at me, then I realised. I totally need to keep a spare bulb!

 

I've heard a few others using the same magnetic ballast for years as well. Sadly with it being out of warranty shop wouldn't help.

 

I've bought a replacement to get me going but I think I might start looking for a new ballast then put this replacement into stores for a backup!

Share this post


Link to post
1 minute ago, mrevolve said:

 

Dude it totally killed the bulb as well. I got back from the shop tried to fire it up and it flashed open circuit at me, then I realised. I totally need to keep a spare bulb!

 

I've heard a few others using the same magnetic ballast for years as well. Sadly with it being out of warranty shop wouldn't help.

 

I've bought a replacement to get me going but I think I might start looking for a new ballast then put this replacement into stores for a backup!

 

It would be worth contacting the manufacturer about the warranty, I think adjustawatt offer 5 years ;)

1 person likes this

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0