Welcome to UK420

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more!

This message will be removed once you have signed in.


Sign in to follow this  
Followers 0
Joolz

Ubuntu/firefox strangeness

122 posts in this topic
:yinyang: no wonder its free...

Share this post


Link to post
;) - It would be *you* of all people who gets to draw the short straw when it comes to your user experience with Linux

lol

Right - first of all - are you using FF3,

yup

and if you go into Edit->Preferences->Advanced in Firefox, you will see in the General tab a tickbox marked 'Use Smooth Scrolling' - make sure that box is ticked. Also, about your privacy - ¿have you ensured that the tickbox marked 'Always clear my private data when I close Firefox' in Edit->Preferences->Privacy is ticked and also investigate the 'Settings' box next to it - ensure that all the things you want deleting are ticked.

yep all thats done but when i close firefox and reopen it it brings me straight to uk420 even though my homepage is set to go to google

It also sounds like you haven't installed Java yet - tell me what happens when you go to Javatester.org - normally, the latest versions of Ubuntu has Firefox automatically ask you if you want to install Flash and Java when you first visit pages that use them.

i'll have to reboot out of windows vista ( which works effortlessly and never crashes or causes any probs) to answer that one :yinyang:

The funky 'spinny 3D desktop' is part of a package called 'Compiz Fusion' - I'll walk you through using it just as soon as we've got these basic hiccups sorted out.

I've got that installed but it doesn't do nowt, same as the desktop effects, having full effects its no different to having no effects :rofl:

*Do* stick with us, though - quite a lot of people give up and go back to Win at a point like this - but I promise you that as soon as you've climbed the initial steep hill at the beginning, you will carry on and never look back. ;)

hmmmm

¿Also, can you tell me what kind of video card you have in this machine?

Radeon X1650 SE

e²a: ¿Have you installed any Firefox addons yet like AdBlock, or NoScript? :yep:

nope

e³a: Also make sure that the tickboxes 'Enable JavaScript' and 'Enable Java' in Edit->Preferences->Content are ticked.

javascript is, java aint

Share this post


Link to post
I run XP pro myself and find it quite user friendly ...Looks like I am also stuck with windows, for the time being.

That's because it's all you've ever known - if you'd started out using the more user-friendly versions of Linux that are out now, you'd be saying exactly the same thing but in reverse. ;)

It actually takes far less key-strokes and effort to install a distro like Ubuntu than it does to install something like XP, type the CD-Key in, track the latest version of all the drivers for your hardware down, make sure that you've put rubbers on your PC before you even *dare* let it anywhere near a 'net connection etc etc.

Once you've ironed out any wrinkles, and got it working sweet - you'd never go back. :yep:

There's a good article y'all should read here. ;)

Google maps is lagging like mad. I can't update nothing, I can't install new packages or anything, totally fookin borked.

I do like Linux though, sorry to hijack the thread but any other linux os should i install? Debian?

Ubuntu *is* Debian, under the hood - it's basically a customised, more n00b-friendly version of it.

¿What video card do you have in the machine where Google Maps is lagging, and do you have the manufacturer's binary driver installed if it's an ATI or an nVidia?

Install the appropriate GFX driver for it, and so long as the card is up to it, 3D stuff will fly. :rofl:

:yinyang:

Share this post


Link to post
¿When you say 'videos' - what kind of videos do you mean - like DivX AVIs, or DVD movies from the shop?

You can install VLC Player which works very well in Linux. :rofl:

:yinyang:

youtube vids and bbc iplayer cause my hd to go mad

Share this post


Link to post

Thanks for the advice Scribble and felix_dzerjinski, I am lacking the confidence in my own computer abilities but i will see how things go, cheers.

H.T.

Share this post


Link to post
I've got that installed but it doesn't do nowt, same as the desktop effects, having full effects its no different to having no effects :rofl:

Before you get all dizzy with the 3D desktop goodness, make sure that you have the proper 3D drivers installed for your GFX card - go to System->Administration->Hardware Drivers and make sure that the ATI proprietary drivers are installed - then go to System->Administration->Synaptic Package Manager and install the fusion-icon package. Then type fusion-icon& into a Terminal window, then play with the settings in there to get what you want to see. To make the Fusion control panel load on every boot, go to System->Preferences->Sessions and tick the box next to 'Compiz Fusion Icon'. ;)

javascript is, java aint

Then tick the Java box - ¿hmm, wonder how it became *unticked*? :yep:

:yinyang:

e²a: To get started with the 3D stuff, make sure that 'Desktop Cube' is enabled in the Fusion control panel, then you can switch desktops with Cntrl+Alt+Left or Right arrows, or even cooler, you can grab the side of the desktop, holding down Cntrl+Alt and the left mouse button on it and dragging across. ;)

e³a: Joolz - until you have Java and Flash installed, you're not going to be having much joy playing online videos. lol

Edited by Scribb|e

Share this post


Link to post
It also sounds like you haven't installed Java yet - tell me what happens when you go to Javatester.org - normally, the latest versions of Ubuntu has Firefox automatically ask you if you want to install Flash and Java when you first visit pages that use them.

i've gone there and it says i need to install mising plugins

which one though ?

post-2-1216210256_thumb.png

Share this post


Link to post

Java SE6. :rofl:

:yinyang:

Share this post


Link to post
Before you get all dizzy with the 3D desktop goodness, make sure that you have the proper 3D drivers installed for your GFX card - go to System->Administration->Hardware Drivers and make sure that the ATI proprietary drivers are installed -

already installed lol

then go to System->Administration->Synaptic Package Manager and install the fusion-icon package. Then type fusion-icon& into a Terminal window, then play with the settings in there to get what you want to see. To make the Fusion control panel load on every boot, go to System->Preferences->Sessions and tick the box next to 'Compiz Fusion Icon'. :doh:

done lol but cant find it in sessions to tick :yep:

Then tick the Java box - ¿hmm, wonder how it became *unticked*? ;)

:yinyang: but ticked now lol

and why when i minimize a screen cant i get it bloody back ?

this is the 4th time i've tried replying, minimizing the screen just loses it grrrrrr!

Share this post


Link to post
Java SE6. :yep:

:yinyang:

installed ;)

Share this post


Link to post
and why when i minimize a screen cant i get it bloody back ?this is the 4th time i've tried replying, minimizing the screen just loses it grrrrrr!

Right-click the bottom taskbar, select Add to Panel, and then select Window List - it must have become uninstalled somehow. ;)

¿Have you installed (from Synaptic - name of package is fusion-icon) and run Compiz Fusion Icon yet? You can also run it from Applications->System Tools->Compiz Fusion Icon - a little blue box icon will appear next to the clock in the top right-hand side of your desktop - right click on it, and select 'Settings Manager' and make sure that 'Desktop Cube' is ticked for starters. :yep:

You'll also want to install Flash player in Firefox - simplest way to do that would probably be to go here and then install Adobe Flash Player when it should ask you.

:yinyang:

e²a: You'll be OK when you've re-installed the Window List applet on your bottom taskbar, but you could have used Alt+Tab to switch between windows, à la Windows. :doh:

Edited by Scribb|e

Share this post


Link to post

computers eh

cant live with them cant live without them

im just glad scribble khows his stuff

hope you get it sorted joolz mate

all the best

twenny

Share this post


Link to post
e²a: You'll be OK when you've re-installed the Window List applet on your bottom taskbar,

done that but now firefox has 'lost' its maximize/minimize/close buttons :stoned:

and where do i find the 3d spinny cube thing :yep:

also in sessions the 3d spinny cube thing not listed so i cant check it :wink:

Share this post


Link to post

The Sessions thing is just so that the Compiz Fusion control panel will load at every boot - to just run it now, go to Applications->System Tools->Compiz Fusion Icon and run it from there.

Then you will have a blue box icon next to where the clock is, right click on it to get the menus up - make sure that Select Window Manager is saying 'Compiz' and then click on 'Reload Window Manager' to see if you can get your window buttons back - don't worry, the missing titlebar buttons is a common symptom until you get the Compiz settings tweaked right - to forgoe spinny 3D gorgeousness in an emergency, for example, you can just choose 'Metacity' in the Select Window Manager menu. :wink:

You want to make sure that 'Desktop Cube' is ticked in the Compiz Fusion Icon's 'Settings Manager' screen. :yep:

:stoned:

e²a: This is what the Compiz Fusion icon and menu look like:

post-17181-1216214539_thumb.jpg

Edited by Scribb|e

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0