Welcome to UK420

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more!

This message will be removed once you have signed in.

Sweet Seeds

Support forum for Sweet Seeds


large.Novedades.png.62482e5d64de6b52b509

1,125 topics in this forum

    • 0 replies
    • 9,758 views
    • 31 replies
    • 2,571 views
    • 0 replies
    • 1,025 views
    • 2 replies
    • 125 views
    • 348 replies
    • 65,026 views
    • 220 replies
    • 62,482 views
    • 104 replies
    • 44,769 views
    • 172 replies
    • 38,984 views
    • 285 replies
    • 32,727 views
    • 37 replies
    • 30,292 views
    • 772 replies
    • 30,226 views
    • 40 replies
    • 24,515 views
    • 387 replies
    • 24,263 views
    • 91 replies
    • 22,093 views
    • 167 replies
    • 20,227 views
    • 218 replies
    • 20,038 views
    • 272 replies
    • 17,642 views
    • 110 replies
    • 16,019 views
    • 215 replies
    • 15,246 views
    • 107 replies
    • 14,793 views
    • 162 replies
    • 14,344 views
    • 97 replies
    • 13,367 views
    • 162 replies
    • 12,784 views
    • 116 replies
    • 12,711 views
    • 51 replies
    • 11,960 views


  • Posts

    • Tommytopper
      what type of lights are you using for veg mate and how high above the plants are they?   im using mh and there 2 ft from the then plants 
    • MK11
      You have checked the fuse in the plug ? They'll be fine,just fire  the light back up asap.
    • hilbilly hifi
      That was my dream man, that i'd be keeping the magnetic ballast as a backup when I did upgrade and that she'd come out of a long storage period and do a little let there be light performance if ever called upon. I've been naughty and used the 400w bulb with it before so maybe that shortened it's lifespan somewhat. Does the vaporizer still work?
    • CannaKay
      No prob mate, I didn't ment that there was something wrong with yer bulb but that was why i had a 36 hour dark period, I also still run a magnetic ballast that is probably older then myself, it was given to me by an oldtimer along with a 1975  master blaster vaporizer , must say that it looks solid as and still fires up my 600w bulb but they're not dimmable so maybe I should be looking for a digital aswel !