Welcome to UK420

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more!

This message will be removed once you have signed in.

2,721 topics in this forum

    • 400 replies
    • 215,775 views
    • 496 replies
    • 20,016 views
    • 330 replies
    • 13,407 views
    • 210 replies
    • 60,419 views
    • 171 replies
    • 15,191 views
    • 169 replies
    • 12,964 views
    • 168 replies
    • 24,036 views
    • 164 replies
    • 8,181 views
    • 162 replies
    • 8,394 views
    • 140 replies
    • 7,519 views
    • 131 replies
    • 4,181 views
    • 126 replies
    • 4,820 views
    • 126 replies
    • 8,841 views
    • 124 replies
    • 10,105 views
    • 116 replies
    • 1,883 views
    • 113 replies
    • 26,125 views
    • 107 replies
    • 4,278 views
    • 105 replies
    • 6,488 views
    • 103 replies
    • 2,724 views
    • 102 replies
    • 5,188 views
    • 101 replies
    • 4,109 views
    • 99 replies
    • 3,946 views
    • 96 replies
    • 6,587 views
    • 94 replies
    • 6,133 views
    • 94 replies
    • 7,351 views


  • Posts

    • pothead11
      Hmm I hear you on the fox filter could I get the kit then upgrade to a fox filter later on ?
    • viper2k
      Hello all! 

      Need some assistance once again determining whats wrong with the plant. 

      It as a OG Kush, about 35 days in the veg. It is grown outside and is watered every other day. This is the only plant of 4 others that is like this. 

      I'm using bio bizz all mix and have not really fed them any nutes except some root-juice after repotting(about 3 weeks ago) and also some acti-vera at the same time. That was on the first watering after the repotting. Used about 1 ml of each on 1.5 liter of water. 

      We had a very hot week here but after that it has been a week with half cloudy weather with some rain. Under heavy rain i took them under cover, since i have no idea what PH the rain water has here. 

      Been checking the pinned post about nutes deficiency but can not really match it to anything, also figured why only this one..    It does not seem to be getting any worse, except the leaves that has that big brown edges. Should i remove them?
       Any ideas guys? 

      Thanks a lot in advance!

      Pictures:       
       
       
    • Gsp1ce
      Cheers fella's  appreciate it. gonna be far out actually owning a pad and can finally do what i want. its an old farm cottage in the scottish borders well away from 'the people'.    
    • Jimboo