Welcome to UK420

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more!

This message will be removed once you have signed in.

2,721 topics in this forum

    • 400 replies
    • 215,775 views
    • 11 replies
    • 164 views
    • 27 replies
    • 525 views
    • 71 replies
    • 2,106 views
    • 2 replies
    • 48 views
    • 13 replies
    • 246 views
    • 2 replies
    • 32 views
    • 39 replies
    • 783 views
    • 3 replies
    • 46 views
    • 21 replies
    • 412 views
    • 8 replies
    • 116 views
    • 30 replies
    • 325 views
    • 7 replies
    • 103 views
    • 4 replies
    • 77 views
    • 9 replies
    • 171 views
    • 45 replies
    • 1,100 views
    • 30 replies
    • 513 views
    • 2 replies
    • 65 views
    • 4 replies
    • 75 views
    • 6 replies
    • 98 views
    • 70 replies
    • 2,891 views
    • 4 replies
    • 116 views
    • 19 replies
    • 265 views
    • 0 replies
    • 44 views
    • 3 replies
    • 104 views


  • Posts

    • pothead11
      Hmm I hear you on the fox filter could I get the kit then upgrade to a fox filter later on ?
    • viper2k
      Hello all! 

      Need some assistance once again determining whats wrong with the plant. 

      It as a OG Kush, about 35 days in the veg. It is grown outside and is watered every other day. This is the only plant of 4 others that is like this. 

      I'm using bio bizz all mix and have not really fed them any nutes except some root-juice after repotting(about 3 weeks ago) and also some acti-vera at the same time. That was on the first watering after the repotting. Used about 1 ml of each on 1.5 liter of water. 

      We had a very hot week here but after that it has been a week with half cloudy weather with some rain. Under heavy rain i took them under cover, since i have no idea what PH the rain water has here. 

      Been checking the pinned post about nutes deficiency but can not really match it to anything, also figured why only this one..    It does not seem to be getting any worse, except the leaves that has that big brown edges. Should i remove them?
       Any ideas guys? 

      Thanks a lot in advance!

      Pictures:       
       
       
    • Gsp1ce
      Cheers fella's  appreciate it. gonna be far out actually owning a pad and can finally do what i want. its an old farm cottage in the scottish borders well away from 'the people'.    
    • Jimboo