Welcome to UK420

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more!

This message will be removed once you have signed in.


Greeno67

Issues with dimmable ballast

Hi people

 

I recently bought a 600w dimmable ballast with a 600w bulb and a 250w MH bulb for when i turned the ballast down to the lower settings. The issue i'm having is that when i put the 250w bulb in and fire it up at 250 on the ballast it only lights up for no more than 10 seconds, then it turns itself off.

 

Does anyone know what the problem could be? 

 

Some help would be much appreciated 

Share this post


Link to post

What make is ? I take it the 600w bulb works ok on 600w setting? Is the 600w bulb a mh or hps bulb ? Some ballest may not be suitable for both hps/ mh bulbs should say somewhere on it ? the more info the better will hopefully generate other peoples advice and experiences (I’m still running magnet ballest)  or could be a dodgy bulb or ballest if you can blag another 250 w bulb from somewhere to try to work out what’s at fault 

Share this post


Link to post

Its an Omega digi-pro ballast with a 600w super HPS bulb and a 250w MH bulb, both Omega aswell. Yeah the 600w bulb works fine. It says on the box that the appropriate bulb should be used for each setting, which is why i got the 250w bulb. I would have to order another one in to check it, I've just emailed the shop to see what they think the problem could be, so i will see what they say before ordering another bulb. 

1 person likes this

Share this post


Link to post

if you have recently bought it, then  send it back, that's my advice.

I bought 4 of them and 3 were faulty, within a week of use 2 stopped working and the other one had its setting knob just turned round and round, you had no idea what setting it was on

sorry to say it, but they are shite ballasts. Send it back and treat yourself to a lumii digita or a lumatek.

Share this post


Link to post
16 hours ago, badbillybob said:

if you have recently bought it, then  send it back, that's my advice.

I bought 4 of them and 3 were faulty, within a week of use 2 stopped working and the other one had its setting knob just turned round and round, you had no idea what setting it was on

sorry to say it, but they are shite ballasts. Send it back and treat yourself to a lumii digita or a lumatek.

No way man, i'm still waiting to hear back from the shop so i will say to them i want to send it back n get something a bit more reliable. Im choking to get my first grow started aswell, now i will have to sort this shit out!  :wallbash: cheers for the info though mate

1 person likes this

Share this post


Link to post

some ballasts cant run MH lamps, check the tech specs for your ballast if you can find them online, though I'd propably take it back & change it for another make of ballast, ie sunmaster.

Share this post


Link to post

How are you getting on with this HPS? What are your thoughts on me either purchasing a 600w dimmable HPS or a 600/1000w LED, both full spectrum. I need to fill a 80x80x160 tent with 1/2 plants in at a time and need some help!

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now