Welcome to UK420

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more!

This message will be removed once you have signed in.


Sign in to follow this  
Followers 0
Guest Buckfacked

Autoplay videos

I'm sure that many of you are a tad annoyed by various sites, especially newspapers, automatically playing videos when you open a page whether you actually want to see the video or not, it certainly gets on my nerves.

If so, here are some things to do if using Chrome or Chromium (Linux version), or any other browser based on Chromium.

First, download the "Disable HTML5 Autoplay" addon for Chrome, which will at least stop many things from playing.

Second, make sure you have AdBlockPlus and Flashcontrol installed. One way that sites have used to get around the HTML5 block is to use animated gifs, and a right click on the gif brings up a nice "block element" option in AdBlockPlus which does what it says, and there is no more unwanted animated nonsense with these images, they simply don't appear. Flashcontrol does what it says, you choose if flash elements are played on a site or not.

Third, and I know this is on a site for Apple users but it works for all versions of chrome, follow the instructions here:- How to Stop Autoplay Video in Chrome 

Result, all the flashing and annoying crap on sites such as the Daily Mail (one of the worst I have come across for this so is a good test) is stopped dead in it's tracks.

I'm working on how to stop the extra "pop up" video windows that appear when you scroll down pages, will add to this thread when I have the answer as I'm sure many of you can't stand that crap as well.

Edited by Buckfacked

Share this post


Link to post

Firefox users

In the address bar type about:config.

That will bring up the gubbins of firefox and how it works.

In the search bar search for media.autoplay.enabled which will more than likely be set to "True".

Right click on that entry and then click "toggle" and it will set to "False" and that should stop all videos autoplaying.

Tested on the same Daily Mail website with a "satisfactory" result, no videos autoplay.


Now just to work on these pesky popup video players that all these sites like.

Share this post


Link to post

Ya dancer, the annoying "popup" video crap on websites is GONE, and it's so simple in Chrome.

Look at the address bar, and you will see a little icon before the "http" which will say "view site information" when you hover the mouse pointer over it. Click on that and you will see an option that says "site settings".

Click on that and you see a list of options for that site only, look for "Javascript" and you will see it says "Allow".

Click on "Allow", a drop down menu will appear and change that to "Block".

Reload the offending page, scroll up and down to your heart's content, no more popup video garbage.

Follow this for any and all sites doing this, each one must be blocked individually or you may lose something you don't want to if you block all Javascript.

Will get back to you regarding Firefox

Share this post


Link to post

Firefox Users

Install the "NoScript" addon. ALL javascript will be blocked. Add exceptions as necessary by clicking on the NoScript icon and changing what you wish changed from "Untrusted" to "Trusted".

Simple as that.

Share this post


Link to post

cheers for the tip on stopping firefox from playing vids all the time :yep:

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0