Welcome to UK420

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more!

This message will be removed once you have signed in.


Search the Community: Showing results for tags 'phosphorus'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to UK420
    • New Members
  • Cultivation
    • Strain Base
    • Breeders Help Desks
    • Compost and Pots
    • Hydroponics
    • Outdoor Growing
    • Propagation, Cloning and Mother Plants
    • Auto Flowering
    • Growroom Design
    • Problem Solver
    • Harvesting and Processing
    • Grow Diaries
    • Cream Of The Crop
  • Cannabis Culture
    • News, Views and Politics
    • Medicinal Cannabis
    • Smokers Lounge
    • Uk420 Competitions
  • Sponsor Support
    • One Tree Horticulture
    • Intense Nutrients
    • Vapefiend - The Vaporizer Specialists
    • DIY LED UK

Calendars

  • Community Calendar

Found 2 results

  1. Evening all had a look in on the lady’s this afternoon and found a couple of leaves looking abit curled up and what looks like darker brown patches appearing it’s only on two of the three cuts I’ve got and not showing at all on the one plant grown from seed. They are all in the same Rdwc system EC is sitting at 0.8 I don’t PH my res as I’m using advance nutrients ph perfect sensi grow line of nutrients the only other thing I add in is silver bullet roots. res temp is 19c lights on is around 24/25c lights off is around 20c light schedule is 18/6 humidity has been in the low side and sits around 40/50 I know this could be abit higher but not sure it would cause this to happen. anyway anyone have a clue of what could be up with them help would be much appreciated. Cheers.
  2. okay guys got some blue cheese plants around 4-5 weeks into flower, theyre real heavy feeders. but one plants going a bit weird. random fan leaves started blotching slightly, came back to the tent after a couple daysof my old man tending it and hadnt told me what happened. the ones that hat started blotching had curld up with big brown patches (doesnt smudge not mold). trimmed the dead fan leaves off flushed the plant and it seemed to slow down. buds and sugar leaves are fine just a few fans. been reading up and put it down to phosporus deficiency. no pics atm but its in soil from seeds and im using old timers bloom and a wee bit of calmag. anything with added phosphorus or something you guys could reccommend seen meal worm tea and stuf like that. im going to grab some pk boost this weekend anyway as im out, you think that'll help or something else i could do with ? any tips appreciated PF