Jump to content


Photo

Problems when switching to flower. Plant Magic


  • Please log in to reply
4 replies to this topic

#1 Twelve12

Twelve12

    Vegging Nicely

  • Full Member
  • PipPipPip
  • 147 posts

Posted 07 April 2012 - 02:23 PM

Hello Guys

I have been having some problems with Plant Magic Coco Coir A+B Soft water.

My veg garden looks magic. My flower garden on the other hand is not so good.


All environment conditions are prime.

I am using RO water with added CalMag+, Plant Magic Coco A+B and I am following the guidelines on the feed schedule. Ph is 6.0 and Ec is 1.0 as these are only foot tall clones. I make sure there is 30% run off.

To start with all growth lightens to a light green rather then the darker vibrant green in veg. stems are soft and weak. Then 1/2 weeks the problems start. Bottom leaf tips brown and point up eventually taking the whole leaf. Middle leaves get white patches then spread. These leaves brown and crisp from tip back to the stems in till they fall off.

It seems like a lot of micro nutrient deficiency and cant see why i should have to add some GH micro to keep these girls thriving.

Has anyone had this problem and does any one know why i could be faced with these problems, slowly wiping my garden out :(

#2 KimboSlice

KimboSlice

    Vegging Nicely

  • Full Member
  • PipPipPip
  • 188 posts

Posted 07 April 2012 - 03:57 PM

this

I've just switched to coco. I bought root stim and pm coco grow, but I wont try the bloom. I'm going to switch to canna for flower.

#3 Godspeed

Godspeed

    Vegging Nicely

  • Full Member
  • PipPipPip
  • 460 posts

Posted 07 April 2012 - 04:50 PM

hggggg

Edited by Godspeed, 07 April 2012 - 04:54 PM.


#4 VRG

VRG

    It's what you make it

  • Lifetime Subscriber
  • PipPipPipPipPipPip
  • 9753 posts

Posted 07 April 2012 - 05:33 PM

All environment conditions are prime.

I am using RO water with added CalMag+, Plant Magic Coco A+B and I am following the guidelines on the feed schedule. Ph is 6.0 and Ec is 1.0 as these are only foot tall clones. I make sure there is 30% run off.

To start with all growth lightens to a light green rather then the darker vibrant green in veg. stems are soft and weak. Then 1/2 weeks the problems start. Bottom leaf tips brown and point up eventually taking the whole leaf. Middle leaves get white patches then spread. These leaves brown and crisp from tip back to the stems in till they fall off.

It seems like a lot of micro nutrient deficiency and cant see why i should have to add some GH micro to keep these girls thriving.


Thats because your feeding them below the recommended dosage.

Just checked the PM site and they recommend a dosage of 3-5ml/l.
Below 3ml/l you are starving them of micro's

When running such a low EC for either young plants or particularly sensitive varieties you will need to add micro nutrient, I would recommend growers ark trace elements.

Or alternatively you should use a feed designed specifically for young plants and then you can use it at full strength.

Hope this helps, VRG.

Edited by VRG, 07 April 2012 - 05:34 PM.

Just living is not enough..
One must have sunshine, freedom, and a little flower.


#5 Twelve12

Twelve12

    Vegging Nicely

  • Full Member
  • PipPipPip
  • 147 posts

Posted 07 April 2012 - 08:40 PM

Makes sense. Although iv run this with GHE 3 part with no difficulties same Ec and ph. I will try upping the food to see what happens I'm just going to bin them anyways.

Cheers for the input guys.


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users