Welcome to UK420

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more!

This message will be removed once you have signed in.


Sign in to follow this  
Followers 0
mikeydoughnut

Plant looking poorly

Hello folks. Bit of a forum lurker being a technophobe. Just dip in and out like.

Right I’m currently got bad azz kush growing in light mix. Just flicked over to flower on Sunday. Only been feeding biobizz grow. Will start to feed bloom in a few days time.

i have however neglected to feed any Epsom salts. I’m fairly new to growing so the thought just passed me by. So I’m thinking that may be my issue. 

ive taken a quick pic this morning. Just shows one leaf but it’s on a few. Rest of the plant looks really healthy. Only been past day or two I’ve noticed anything.

Edited by Cursed
Photo not uploading to post

Share this post


Link to post

hey, sorry but its aganst the rules to post off site hosted images. If you could upload here that would be great. Sorry and thanks.

 

 

Share this post


Link to post

Thanks for the help regarding. Photos. I can see a photo now on the post but will others see it? Trying to do it on me phone but it’s proving difficult. 

Share this post


Link to post

theres another one for phones, i'll try find it now :yep:

 

if the pic is uploaded to the site and its been added to the post then everyone should be able to see it.

1 person likes this

Share this post


Link to post

Cheers cursed it’s much appreciated. Hopefully someone can help put me out me misery and we can get this lickle beaut back to full health.

Share this post


Link to post

photo not showing for me mate.

Share this post


Link to post

I seen the pic and to me it is right near to pot side and more than likely been damaged and nothing to worry about, just crack on and stop worrying.

Share this post


Link to post

Me n me girls. Aye that was my initial though. It’s a bushy lickle bugger so those bottom leaves do get a fair bit of water on them. I do endeavour to water just before lights out to prevent the light burning her through the odd spots of water. But now she’s drinking about 3 litres every water it’s kinda soaking some of those bottom leaves. Time for a trim perhaps? 

Following owds bio bizz schedule so they’re due an Epsom bath in a few days anyroad. 

Cheers folks

Share this post


Link to post

It won,t hurt to remove the bottom leaves, they are only due Epsom salt if you have a Mag def it,s not a preventative it,s a solution.

1 person likes this

Share this post


Link to post

I'd recommend watering at lights on rather than just before lights off.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0