Welcome to UK420

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more!

This message will be removed once you have signed in.


Kojiro

Thread moved?

I posted a thread earlier today. And now its moved, its tagged on to a thread i posted weeks ago?? Any reason why this has happened?

Share this post


Link to post

Because it looked to me you were getting the same problems as you posted before. If folk see that they can help easier because there is more info

 

By the way what you have looks to me to be a calcium deficiency which can be caused by quite a few problems

 

Owd

Share this post


Link to post

Hi. I never thought of Calcium. The ph of my water is 7.5. Do you think ph is the problem?

Share this post


Link to post

You are growing in compost so your ph isn't a problem as the soil will buffer that easily

 

Owd

1 person likes this

Share this post


Link to post

Ok. Thanks. I'll look into calcium defiency.

Share this post


Link to post

Have ordered some Advanced Nutriants Revive. But i wont get it untill Tuesday. The plants are getting worse by the day. Is there anything you can suggest to try and slow down the problem?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now