Welcome to UK420

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more!

This message will be removed once you have signed in.


Sign in to follow this  
Followers 0
Guest bobbert

Every day now , whats wrong with these guys?

21 posts in this topic

Any ideas guys?

3ml growers ark per litre, coco , 3 litre pots , due a pot up.

Growth is good, roots have come along a lot since my last disaster.

ph around 5.9 - 6.

temps good.

edit - still in veg period. Hand watering although I did submerge the pots in a bucket last night.

Edited by bobbert

Share this post


Link to post

Looks like mag deficiency to me. personally I would add some epsom salts to the next feed and see if it improves. Green veins and yellow leaves is mag def, yellow leaves and veins is N deficiency is what I was told + coco loves Mag and cal!

1 person likes this

Share this post


Link to post

Where can I buy calmag? Ive been reading up and people recommend it , or will epsomsalts give me both cal and mag?

Share this post


Link to post

Epsom salts will give you the mag but there is no calcium in it.

Share this post


Link to post

what ec??

Share this post


Link to post

No idea what ec it is at i'm afraid.

Share this post


Link to post

Purchased some epsom salts today , how do I use them?

Do I mix it in with a full strength or weaker feed? Also how much?

Share this post


Link to post

disolve 70g in 9ltrs water AND SPRAY DIRECTLY ON TO PLANTS

SOrry was shouting :spliff:

Share this post


Link to post

Can I not add it to their feed then?

Share this post


Link to post

Can I not add it to their feed then?

You gottta check the content on your regular feed and see how much more might be required.

What nutes are you using??

Do you have hard water / soft water / RO water?

You could just suck it and see. experiment by adding a gram or 2 per gallon of feed.

Share this post


Link to post

I am using growers ark 3ltr per litre of water ,very hard water area.

Share this post


Link to post

Strange one.

I assume your an accomplished grower so all the basics will have been checked.

Have you ever had Mag issues before? I have fairly hard water and never had cal/mag issues.

First time on these nutes?

Share this post


Link to post

First time in coco , apparently it is a common thing with coco.

Share this post


Link to post

I'm venturing into coco myself at the moment, week 4 flower now.

I was initially keeping Ph at 6-6.2 but was showing some N defficiency at around week 4 veg.

On another forum Green Ninja told me to do drop it to 5.5-5.7 in veg and they coloured up and look very healthy now.

I did this even though the PM+ chart says 5.8-6.0

I use drippers and a wilma big4. I think the ideal PH range for coco stays the same whether your passive or active.

It may not be just N being locked out (as i'm sure your aware, re PH flucts), but i'm sure the correct PH range will help ballance the mixture.

Share this post


Link to post

N is uptaking better at a lower ec ie around 5.6-5.8, does look like mag def tho from the pics a heaped tablespoon to10 litres water is ideal. :yinyang:

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0