Welcome to UK420

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more!

This message will be removed once you have signed in.


Search the Community: Showing results for tags 'question 2'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to UK420
    • New Members
  • Cultivation
    • Strain Base
    • Breeders Help Desks
    • Compost and Pots
    • Hydroponics
    • Outdoor Growing
    • Propagation, Cloning and Mother Plants
    • Auto Flowering
    • Growroom Design
    • Problem Solver
    • Harvesting and Processing
    • Grow Diaries
    • Cream Of The Crop
  • Cannabis Culture
    • News, Views and Politics
    • Medicinal Cannabis
    • Smokers Lounge
    • Uk420 Competitions
  • Sponsor Support
    • Intense Nutrients
    • Vapefiend - The Vaporizer Specialists
    • DIY LED UK
    • Gro-zone Hydro

Calendars

  • Community Calendar

Found 1 result

  1. help guys , my autos are in flower , but a bit slow my fault ! not a good light , i think.. got a 600w led over now , 1 question fan leaves at bottom are curling up should i take them out we are in week 15. red dragon. barneys farm. question 2 manage to do my 1st clone in rockwool plug there is one solid root on the side off plug , what is the next step to put in soil ?? cant see much on forum for clones do i try to take out the rockwool or bury it with the plug in comp, regards all in june , geo geo ..