Welcome to UK420

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more!

This message will be removed once you have signed in.


Search the Community: Showing results for tags 'Soft water'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to UK420
    • New Members
  • Cultivation
    • Strain Base
    • Breeders Help Desks
    • Compost and Pots
    • Hydroponics
    • Outdoor Growing
    • Propagation, Cloning and Mother Plants
    • Auto Flowering
    • Growroom Design
    • Problem Solver
    • Harvesting and Processing
    • Grow Diaries
    • Cream Of The Crop
  • Cannabis Culture
    • News, Views and Politics
    • Medicinal Cannabis
    • Smokers Lounge
    • Uk420 Competitions
  • Sponsor Support
    • One Tree Horticulture
    • Intense Nutrients
    • Vapefiend - The Vaporizer Specialists
    • DIY LED UK

Calendars

  • Community Calendar

Found 3 results

  1. Multi-Strain 2018

    From the album Multi-Strain 2018

  2. Hey My plan was to use PM supreme with OT grow and bloom ( along with granuels and maybe fishmix) but now Im unsure if my water supply is appropriate. From an online search my local water supply comes from the welsh mountains, says it is soft with a ph 7.64, and has a conductivity 128.00 2500us/cm (have a list of metals and other stuff thats in the water if that helps Im a bit out of my depth with this stuff) I read OT is suited to hard water, will this be problems ? Should I be using a better or more suitable organic feed that you guys can recommend? Thanks again your help is appreciated
  3. My second grow in my new space hasn't gone too well so far and really want to bring them back to health before 12/12. I cooked the roots early on with underfloor heating issues. I have now isolated the room but I think this may've prevented nute uptake, I got yellowing so thought they MUST be hungry so fed 2ml of Oldtimer Grow and burnt them. Lost a few lower fan leaves. I'm in Plagron Batmix so thought they should have had plenty of food for vegging without me having to add any so I was very cagey about feeding. I didn't riddle the Batmix (didn't have time and to riddle a bag of this stuff and break down all the lumps, twigs and timber would take an hour or 2 I reckon with my little sieve!) but can't imagine this is the problem and I did try and break it up by hand and with a trowel. I potted up a few days ago to 3.5lt using Batmix and PM Granules (is it wise to mix nute brand's 'ecosystems'?). They were topped at the same time. Because I have dropped to one light I now have 9 girls-3 Cream Caramel and 6 Psychosister. They are all smelling good but a little pale. Next I realised I have very soft water compared to where I grew before so on the last watering I just added 0.5ml/lt PM+ Magne-Cal. -My temps range with a thermometer in the shade at root level is 22°C-28.5°C. -Lights on 20/4. -Airflow is 200mm out the window with a reducer to a 250mm outlet and 150mm in from the room running off an SMS Hybrid. Both with oversized carbon filters. -I have them sat on a 100mm sheet of Celotex too for good measure. -Also have an oscillating fan and 2 clip-ons churning the air in the tent. -Bulb is about 2 feet/40cm away but I should measure it to be sure. A couple of pics that hopefully show what I mean... Cream Caramel The Final 9 Do I wait and see if the pot up helps them recover or am I missing something obvious? Heeyeelp!! in my best Penelope Pitstop voice.