Welcome to UK420

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more!

This message will be removed once you have signed in.

Sweet Seeds

Support forum for Sweet Seeds


large.Novedades.png.62482e5d64de6b52b509

1,115 topics in this forum

    • 7 replies
    • 1,453 views
    • 11 replies
    • 3,216 views
    • 8 replies
    • 886 views
    • 4 replies
    • 794 views
    • 18 replies
    • 1,804 views
    • 96 replies
    • 5,572 views
    • 4 replies
    • 856 views
    • 16 replies
    • 1,955 views
    • 9 replies
    • 2,229 views
    • 16 replies
    • 1,576 views
    • 16 replies
    • 1,322 views
    • 13 replies
    • 1,601 views
    • 75 replies
    • 3,755 views
    • 4 replies
    • 3,286 views
    • 42 replies
    • 6,082 views
    • 8 replies
    • 3,587 views
    • 24 replies
    • 2,117 views
    • 162 replies
    • 14,298 views
    • 3 replies
    • 1,147 views
    • 41 replies
    • 4,403 views
    • 5 replies
    • 749 views
    • 9 replies
    • 903 views
    • 116 replies
    • 12,684 views
    • 19 replies
    • 3,472 views
    • 3 replies
    • 906 views


  • Posts

    • doominik
      I dont have anyone unfortunately.  I am the only "working one" in the family 
    • Hydro-H
      If your able to source some cuttings from somewhere, I would suggest that and put them under 12/12 straight away. You'll get a heavier harvest than any autos and it would suit your time frame a lot better. 
    • Jammo85
      Sorry to create another post, I’ve managed to get down shed today to have a look and plants are getting worse each day (broke my leg and wife been taking pictures for me most days)    when the issue started last week lights on temps were 35c  roots were 18c    ive got lights on to 29c since Wednesday  roots now 21/22c lights off.   its like I’ve burnt them and they starving now not taking any thing on board.
      when feeding ive never gone Over 1.7ec    this week they only had weaker 1.0ec pk13/14 on Monday. 
      then water Tuesday  water Thursday  due to drink today. 
        plants are just over 4 weeks in flower (four weeks Wednesday gone)  ive been feeding Canna Terra nutes and a calmag, started using Canna Pk 13/14 last week. have also been using Canna Rhizotonic Canna Boost and Biobizz Alg g mic as I had that there....started grow in Bio Bizz but didn’t think it was doing much.    todays pictures are 
          I started a thread start of the week where I thought it was a calmag issue as I’ve previously had that.   heres a link to the thread i started a week ago where I thought it wasn’t so serious, lots of pictures as they worsen throughout the week..... now I think I’ve killed them so the new Topic hoping someone can help. (Sorry if you’re not allowed to open another topic plz delete, just at a loose end and on verge of nervous brake down starting at pictures of my girls dying)       
    • Hydro-H
      Looks like lockout, with possible salt build. This has caused no uptake of cal/mag hence the browning on the leaves. I wouldn't worry though as you say your close to harvest I would start flushing now for the last couple weeks just ph'd water to flush out those salts and improve flavour and burn of the final product.