Welcome to UK420

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more!

This message will be removed once you have signed in.


Subforums

  1. Micro-Growing & Experimental

    For Compact Fluorescent and LED Growers

    8,928
    posts

8,732 topics in this forum

    • 0 replies
    • 38 views
    • 2 replies
    • 84 views
    • 4 replies
    • 196 views
    • 2 replies
    • 83 views
    • 16 replies
    • 233 views
    • 1 reply
    • 110 views
    • 2 replies
    • 88 views
    • 0 replies
    • 84 views
    • 1 reply
    • 106 views
    • 0 replies
    • 83 views
    • 13 replies
    • 310 views
    • 31 replies
    • 959 views
    • 0 replies
    • 42 views
    • 2 replies
    • 90 views
    • 5 replies
    • 225 views
    • 0 replies
    • 45 views
    • 3 replies
    • 82 views
    • 3 replies
    • 158 views
    • 58 replies
    • 11,239 views
    • 4 replies
    • 77 views
    • 0 replies
    • 65 views
    • 2 replies
    • 96 views
    • 2 replies
    • 97 views
    • 5 replies
    • 209 views
    • 5 replies
    • 453 views


  • Posts

    • FARMER G
      I take it from the above your dealing with overseas going by the crazy plug adaption...   Then im guessing its either a snide or a sub-par product...   Farmer G 
    • CuriousGreenHand
      get in touch with the manufacture's they are obligated to warranty, if ebay is not direct e.g 3rd party seller
    • FARMER G
      It would hold at a guess but you have already identified the problems with it being plasterboard and the problem it will cause if knocked etc    The difference between plasterboard and chipboard in cost is minimal is it not ?   Farmer G 
    • Jammo85
      No, it’s a two prong plug going into out UK plug    it’s come back on now after 11 mins off    I’ll time it again, it’s not even got any ducting connected now so it’s not doing any work as such. Also not in box